show running configuration
PERDL1#show run
Building configuration...
Current configuration : 2534 bytes
!
! Last configuration change at 11:39:00 EET Tue Nov 7 2023
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname PERDL1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EET 2 0
!
!
!
no ip domain-lookup
ip cef
!
!
!
!
!
vtp mode off
no ipv6 cef
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name HCG
revision 1
instance 1 vlan 1000
instance 2 vlan 20, 25
!
spanning-tree mst 2 priority 40960
!
vlan internal allocation policy ascending
!
vlan 20
name Level20
!
vlan 25
name Level25_Yours_will_be_different
!
vlan 1000
name Staff
no cdp run
!
!
!
!
!
interface Ethernet0/0
description Link to Core
no switchport
ip address 10.1.255.1 255.255.255.252
ip access-group BLOCK_PHISHING in
ip ospf 1 area 1
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode access
shutdown
!
interface Ethernet0/2
switchport trunk encapsulation dot1q
switchport mode access
shutdown
!
interface Ethernet0/3
switchport trunk encapsulation dot1q
switchport mode access
shutdown
!
interface Ethernet1/0
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Ethernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Ethernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Ethernet1/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan20
description Level 20 Guest LAN
ip address 10.1.20.2 255.255.255.0
ip access-group GUEST_NETWORK_POLICY in
standby 1 ip 10.1.20.1
standby 1 priority 95
standby 1 preempt
ip ospf 1 area 1
!
interface Vlan25
description Level 25 Guest LAN
ip address 10.1.25.2 255.255.255.0
ip access-group GUEST_NETWORK_POLICY in
standby 1 ip 10.1.25.1
standby 1 preempt
ip ospf 1 area 1
!
interface Vlan1000
description Staff LAN
ip address 10.1.128.2 255.255.255.0
standby 1 ip 10.1.128.1
standby 1 preempt
ip ospf 1 area 1
!
router ospf 1
!
ip forward-protocol nd
!
!
no ip http server
!
ip access-list standard BLOCK_PHISHING
permit 1.2.3.4
deny 1.2.3.4 0.0.0.3
permit any
!
ip access-list extended GUEST_NETWORK_POLICY
permit ospf any any
deny ip any 10.0.0.0 0.255.255.255
permit tcp any any eq www 443
permit icmp any any echo
permit udp any host 224.0.0.2 eq 1985
deny ip any any
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
PERDL1#